内容字号:默认大号超大号

段落设置:段首缩进取消段首缩进

字体设置:切换到微软雅黑切换到宋体

京东云_被墙了套cdn_高性价比

2021-07-10 12:09 出处:欧普曼云计算 人气: 评论(0

我们已经发布了新版本的sapcloudsdk。具体来说,新版本中提供了以下组件:

版本3.24.0中的Java库版本1.24.1中的JavaScript库v38版的持续交付工具包

在这篇博文中,我们将引导您了解这些版本的亮点。要获得完整的概述,淘客返利系统,请访问我们的Java库、JavaScript库和持续交付工具包的发行说明。发行说明还包括到目前为止我们所有发行版的更改日志。在文章的最后,您将看到一组关于如何更新到新版本的说明。

您可以将SAP Cloud SDK for Java的依赖项更新到3.24.0版本,并从Maven Central获得新版本。

这是一个稳定性版本,有一些小的改进。

有关详细信息,请查看完整的发行说明。

theSAP Cloud SDK的JavaScript库现在在1.24.1版本中可用。

我们增加了对所有字符串、数字和日期相关过滤函数的支持。导入filterFunctions并在filter中使用,例如filter(filterFunctions.startsWith筛选器函数.startsWith(业务伙伴名).equals(true)).

我们的ODataV4支持正在通过许多改进得到扩展,例如生成器中对Edm类型的特定解析。如果您已经使用了ODataV4的实验性功能,请确保始终包含最新的SAP Cloud SDK版本。

与往常一样,物联网培训,完整的发行说明包含此版本中所有改进的列表。

我们还发布了开箱即用的连续交付产品v38版本,包括现成的Jenkins服务器和完整的交付工具包。

管道现在在sonar中的非生产性、非PR分支中设置branchName属性。这允许在多分支设置中使用sonar,因为sonar知道检查所指的分支。请注意,好评返现,并非所有版本的sonar都提供此功能。

您可以在完整的发行说明中找到进一步的修复和改进。

Java库

要更新现有项目中使用的SAP Cloud SDK Java库的版本,请按以下步骤进行:

打开pom.xml文件文件位于项目的根文件夹中。找到dependency management部分,并在其中找到sdkbom依赖项。将该依赖项的版本更新为3.24.0.

这样,由于采用了"物料清单"(BOM)方法,您已经完成了。您的依赖关系应该是这样的:

如果您从3.0.0之前的版本更新,请查看我们的迁移指南。

如果您在SAP云应用程序编程模型的项目中使用SAP Cloud SDK,请将SDK bom替换为SDK模块bom,以仅更新SDK模块的版本,而不是进一步的依赖关系。现在您可以重新编译您的项目(注意兼容性说明),并利用3.24.0版SAP Cloud SDK的新功能。

当然,通过运行Maven archetypefor Neo或Cloud Foundry的-DarchetypeVersion=3.24.0(或RELEASE),您还可以生成一个从一开始就使用3.24.0版本的新项目。

JavaScript库

要更新现有项目中使用的SAP Cloud SDK JavaScript库的版本,大数据风控,请在您的根文件夹中使用命令npm update模块。请注意,这还将更新其他模块,除非您明确指定要更新的包。如果您想事先检查将要更改的内容,请使用npm-outloaded.

连续交付工具包

如果您使用的是固定版本的管道(从v7开始推荐),请使用以下命令更新连续交付工具包,在cx服务器所在的服务器上运行:

要了解社区中其他人如何使用SAP Cloud SDK,您可以查看更多相关的博客文章。

您对某个特定主题感兴趣吗?搜索问答地点可能会有帮助?请随意提问,不要忘记选择标签SAP Cloud SDK。

如果您是SAP Cloud SDK新手,低价的云服务器,请按照我们的教程开始并获得第一手的练习。

分享给小伙伴们:
本文标签: 京东性价比

相关文章

评论

发表评论愿您的每句评论,都能给大家的生活添色彩,带来共鸣,带来思索,带来快乐。

签名: 验证码: 点击我更换图片

评论列表