手机版

当前位置:主页 > 云主机 > 技术博客 >

对象存储_企业邮箱手机如何登陆_评分榜

时间:2021-09-28 15:57:37|来源:欧普曼云|编辑:欧普曼云|点击:

对象存储_企业邮箱手机如何登陆_评分榜

As I tried to setup my new Mac with Mac OS Sierra to allow development of SAP Kapsel applications, I have realised that there are a few things different to the last installations. Because of this I decided to write this short documentation together with my colleagues Tim Netzlaf and Aram Soltanian.

The goal of this documentation is to have a working scenario and to be able to develop Kapsel Apps in Eclipse for Android and iOS and to let them run in a simulator from Eclipse.

At first we will install the necessary components.

Even Java is already installed on Mac at rollout, we want to get the most actual Version of Java SDK installed. We download the Java SDK from this location:

#javasejdk

We simply run the DMG installer as usual and Java will update to the latest version.

At the moment of writing this document, the most actual Version of SMP3.0 SDK is SP13 PL03. If we have no SDK installed yet, it is enough to download SP13 PL0 to PL03 from the website and install it in correct order. It is not necessary to install all Versions prior to SP13, but it is necessary to install SP13PL00 first. We need to install SP13PL01 and SP13PL02 before installing PL03, so we do always install all Patches of a ServicePack in correct order.

We will download the files from source: https://support.sap.com/swdc which opens the following screen:

We select the grey box "Software Downloads" and on the next screen "by Alphabetical Index (A-Z)" by pressing the ">" sign in the front .

Under the "M"-Folder we will find "SAP Mobile Platform SDK" and select "SAP MOBILE PLATFORM SDK 3.0" on the next screen. On the following screen we select "SUPPORT PACKAGES" and then "SAP MOBILE PLATFORM SDK" again on the next screen.

Now a list of all available ServicePack (SP) and PatchLevel (PL) Files is shown.

First we have to select the correct operating system. In our case it is MAC OS.

After that we can download the necessary files. I have marked them already in the following screenshot.

There are 2 options available:

Once all files are downloaded to the local machine, we need to install them one after the other in correct order.

In my case the first file would be SMPSDK30013_0_21011833.TGZ and it unpacks to folder ebf26454. The folder contains a file named "InstallSDK.command" that we start with a double click. It takes a while to open and we simply follow the installation instructions. Please do not use the setupMacOSX.jar file, cause it simply will not work.

Once the installation of the EBF is complete, delete the EBF Folder and continue with the next PL until all files are installed.

We need NODE.JS at least to get NPM. This will allow us to install CORDOVA from the command line. There are 2 options to install this file.

By the first option we show how to download the files via a webpage. We encountered several issues with the latest Version, so we usually take the previous version and use it. Usually that solves the open issues.

Go to: https://nodejs.org/en/

This will open the following screen and as mentioned we select Version v4.5.0 TLS. The combination of V6.6.0 that is available for download on the WebPage and MacOS Sierra caused issues in the installation and we have not been able to get a complete Cordova installation using this download.

Once Version 4.5.0 is downloaded, simply run the installer and it will install NPM and NODE.JS on your machine.

AThe second option will use the terminal command line and HOMEBREW. It is a little handcrafting and so not the simple drag and drop process, but it gives us more control and for us the more reliable result. Please use Terminal and run through the following process:

First we install HomeBrew on our machine:

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

After this initial installation is complete, update brew just to be on the safe side

brew update

and now we will check the installation by using

brew doctor

Make sure it has no recommendations and warnings. If there are any like in the following screenshot, please correct them before you continue:

in this case it informs us about some issues with the path. To solve this it is necessary to change file .bash_profile using the command

sudo nano ~/.bash_profile

and enter the following line

export PATH="/usr/local/bin:/usr/bin:$PATH"

After the changes are complete, do not forget to reload the new settings by typing:

source ~/.bash_profile

If you have changed the PATH Variable, type set and make sure the $PATH is still correct and has no special characters. Sometimes the editor mixes up with the " sign and the path will be corrupted. If you see a path with numbers inside, like in this example:

…m:/usr/local/mysql/bin:?\200\234/Users/…

Then you need to check the .bash_profile again, especially make sure the " signs are set correctly.

Ok, your brew doctor check does not give any more issues and recommendations, then we finally continue with installing node

brew install node

After this step has completed without errors, the preparation is done and we can install cordova in the next step. This will test our node installation as well.

To install cordova we open the terminal again and we type

sudo npm install –g cordova

After entering the admin password, the process will continue automatically, it will download the necessary files and install cordova on the local machine.

To check the installation, we build a small project:

Move to our documents folder and run the following commands:

Cd ~/documents/workspace

Cordova create testApp com.placeworkers.testapp testApp

Cd testApp

Cordova platform add ios

Cordova prepare

Cordova run

If everything is fine, it will come back with the following screen in the emulator:

Copyright © 2020-2021 深圳市飞博可科技有限公司 版权所有 备案号:粤ICP备17063389号